Setup OneNet Anywhere on Linux (Ubuntu 14.04)

Please note: screenshots may reflect older versions of driver installation, but each Step and Driver Link is correct

Icon

 

Step 1

Open terminal.

Step 2

Run two commands:

sudo apt-get install gksu


sudo apt-get install gdebi

Step 3

Enter password when prompted, then enter Y to continue.

Step 4

Download the Aruba VIA VPN client via-3.0.1 (1).92621-ubuntu1204-x86_64_bin


Step 5

Right click on the installer and click Properties.

Step 6

Click on Permissions tab, check the Allow executing file as program box, then Close window.

Step 7

Double-click the installer.

Step 8

Begin the Setup Wizard by selecting Next.

Step 9

Check the I agree to the terms of the license box, then select Next.

Step 10

Enter your password and select OK.

Step 11

Select Finish.

Step 12

The Aurba VIA icon has now been added to your desktop and the menu bar.

Step 13

Select Click to download VPN profile


Step 14

Type vpnonenet.mq.edu.au into the required field, followed by your OneID and Password.

Then select Download.

 

Icon

Note: a second OneID username/password authentication is required to connect the VPN.

Enter your OneID credentials to continue.

Step 15

Select CLICK TO CONNECT.

Step 16

You are now connected to the Macquarie OneNet Anywhere VPN network.

Step 17

To disconnect from the VPN network, select the Virtual Intranet Access (VIA) icon on your desktop.

Step 18

Select CLICK TO DISCONNECT.

Step 19

OneNet Anywhere VPN network in now disconnected.

Close Window.


  • No labels

10 Comments

  1. Command line instructions for Ubuntu 16:

    1.       Install dependency package  `apt-get install gdebi-core`
    2.       Download your distro’s binary, set as executable and run (eg, ./via-3.0.0.82618-ubuntu1204-x86_64_bin)
    3.       Accept the license terms
    4.       ./via-cli session start
    5.       ./via-cli profile load vpnonenet.mq.edu.au <oneID>  <password>        # This will generate a profile and hash password in it
    6.       ./via-cli connect

     

  2. wrong spelling at STEP 2

    sudo apt-get isntall gksu

  3. Hi all,

     

    Any ideas how to get this working for Ubuntu 17?

    VIA-Client crashes for me on 17.10

     

    Cheers,
    Tony

  4. The 6 year old (!) Ubuntu 12 binary provided will not install on Ubuntu 18 because it requires gksu, which is no longer available. Any chance of getting a more up to date client?

    1. Hi Anthony,

      Our IT Network Engineer has been in contact with the vendor - unfortunately, an updated client is not available at this time.

      As soon as an update becomes available, this wiki resource page will be updated.

       

      Please see the vendors response below:

      "Aruba Via 3.0  only supports Ubuntu 12. Aruba Via supports Ubuntu 12 , 14 , 16 .  The Ubuntu 18 has just been released on April 26th 2018.

       In future releases of Aruba VIA , it is expected to cover Ubuntu 18 also."

      • Vigneash from Aruba TAC
  5. Hi Andrew, thanks for following up on this. The response suggests there are versions more recent than Via 3.0 that officially support Ubuntu 14 and 16. It won't solve the Ubuntu 18 problem but it would be good to provide those here, they'll probably work better than the nominally Ubuntu 12 only version for most people.

    Funny that they use the fact that Ubuntu 18 has 'just been released' (4 months ago) as an excuse. The root cause is that they're still using gksu, which has been deprecated since 2013. It's only become an issue with Ubuntu 18 because, after 5 years, Ubuntu have finally removed it. They had time to avoid this problem.

    Is it possible to access the VPN without the client? Usually these VPN apps just reduce the amount of configuration you need to do to get connected.

    1. Hi Anthony,

      The latest version (v3.0.1) is the one we have at Step 4,  which supports up to Ubuntu 16. 

      At this point in time, connecting to the VPN requires the VIA client. If this changes, we will communicate and update this wiki page.

  6. Anthony Horton actually you can still use the client above just fine although you do need to install `gdebi-core` first. I just did this on a 19.04 install.

    The trick is that the dumb graphical installer wants to use `gksu`, but if you call the client from the command line with some parameters it just puts it into text mode, e.g. assuming you rename the file to `vpn-installer`, just type: `sudo vpn-installer --help`. This will prompt you via the cli to accept the license and then this should give you `via-cli` in the `$PATH`.

    I have this little script in my `$HOME/bin/start-mq-vpn` (add your MQ ID to not get a prompt):

    ---

     

    #!/bin/bash -e

    if [ "$EUID" -ne 0 ]
      then echo "Please run as root"
      exit
    fi

    # trap ctrl-c and call ctrl_c()
    trap ctrl_c INT

    function ctrl_c() {
            echo "** Trapped CTRL-C"
            via-cli session stop
            exit
    }

    USER="${1:-mqXXXXXXXXX}" # <-- ENTER MQ ID HERE

    #read -p "Enter username: " USER
    read -s -p "Enter Password for ${USER}: " PASS

    # WARNING Kill all existing proceses with 'via' in name
    if [[ $(pgrep via) ]]; then
            echo "Removing old instances"
            pgrep via | xargs sudo kill -9
    fi

    echo "Starting service"
    via-vpn-srv
    sleep 5
    via-cli session start
    echo "Clearing profile"
    via-cli profile clear
    echo "Loading profile"
    via-cli profile load vpnonenet.mq.edu.au "${USER}" "${PASS}"
    echo "Connecting"
    via-cli vpn connect --username "${USER}" --userpass "${PASS}"

    echo "Press [CTRL+C] to stop.."
    while true
    do
            sleep 1
    done

    ---

  7. Hi all,
    I got successfully connected to my computer at my workplace by:

    $ sudo apt install gdebi

    $ sudo ./via-3.0.1.92621-ubuntu1204-x86_64_bin --help

    $ via-ui <- here you actually login with your OneID

    And then you use:

    $ ip a

    to learn the internal IP address of your university computer.

    And then:

    $ ssh xxx.xxx.xxx.xxx

    to connect to it.

     

    PS: the script by Wilfred Gee didn't work for me stopping with VIA_ERROR_NOACCESS.

  8.  

    Latest Via clients (which support newer Ubuntu) are available via this SharePoint link and is maintained by ICT Networking team.

    https://mqoutlook.sharepoint.com/:f:/s/o365-group-infrastructureteam/network_team/Ehn2r2JmFdZBvXNT2snRedEBu1g8U0ySY5D-42zozSIvtQ?e=m4ESjE